use strict;
my $str = 'asss
334445
33sas323
sxs23344s
dd34444
5555003234\\_323
233-444
233_444
33-.444
22 2334
33+3-322
-310 23
°10
10%
222/223
334%22
22&222
210=10
';
my $regex = qr/^([0-9-_.,:; +<>#´`"?!§°\\*()%$\/&=|Ø]{1,})$|^([0-9.,k]{1,})$|^([0-9 .,|\-]{1,}?°C)*$|^([0-9 .,|\-"\/]{1,}?x?)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}