#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9-_.,:; +<>#´`"?!§°\\*()%$\/&=|Ø]{1,})$|^([0-9.,k]{1,})$|^([0-9 .,|\-]{1,}?°C)*$|^([0-9 .,|\-"\/]{1,}?x?)*$"
Local $sString = "asss" & @CRLF & _
"334445" & @CRLF & _
"33sas323" & @CRLF & _
"sxs23344s" & @CRLF & _
"dd34444" & @CRLF & _
"5555003234\_323" & @CRLF & _
"233-444" & @CRLF & _
"233_444" & @CRLF & _
"33-.444" & @CRLF & _
"22 2334" & @CRLF & _
"33+3-322" & @CRLF & _
"-310 23" & @CRLF & _
"°10" & @CRLF & _
"10%" & @CRLF & _
"222/223" & @CRLF & _
"334%22" & @CRLF & _
"22&222" & @CRLF & _
"210=10" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")