import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9-_.,:; +<>#´`\"?!§°\\\\*()%$\\/&=|Ø]{1,})$|^([0-9.,k]{1,})$|^([0-9 .,|\\-]{1,}?°C)*$|^([0-9 .,|\\-\"\\/]{1,}?x?)*$";
final String string = "asss\n"
+ "334445\n"
+ "33sas323\n"
+ "sxs23344s\n"
+ "dd34444\n"
+ "5555003234\\_323\n"
+ "233-444\n"
+ "233_444\n"
+ "33-.444\n"
+ "22 2334\n"
+ "33+3-322\n"
+ "-310 23\n"
+ "°10\n"
+ "10%\n"
+ "222/223\n"
+ "334%22\n"
+ "22&222\n"
+ "210=10\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}