# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\n)\[.*\]\n+(?=\[)"
test_str = ("\n\n"
"mssql.min_error_severity = 10\n\n"
"mssql.min_message_severity = 10\n\n"
"mssql.compatibility_mode = Offmssql.secure_connection = Off[Tidy]\n\n"
"tidy.clean_output = Off\n\n"
"[soap]\n"
"soap.wsdl_cache_enabled=1\n\n"
"soap.wsdl_cache_dir=\"/tmp\"\n\n"
"soap.wsdl_cache_ttl=86400\n\n"
"soap.wsdl_cache_limit = 5\n\n"
"[sysvshm]\n\n"
"[ldap]\n"
"ldap.max_links = -1\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.