import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\n)\\[.*\\]\\n+(?=\\[)";
final String string = "\n\n"
+ "mssql.min_error_severity = 10\n\n"
+ "mssql.min_message_severity = 10\n\n"
+ "mssql.compatibility_mode = Offmssql.secure_connection = Off[Tidy]\n\n"
+ "tidy.clean_output = Off\n\n"
+ "[soap]\n"
+ "soap.wsdl_cache_enabled=1\n\n"
+ "soap.wsdl_cache_dir=\"/tmp\"\n\n"
+ "soap.wsdl_cache_ttl=86400\n\n"
+ "soap.wsdl_cache_limit = 5\n\n"
+ "[sysvshm]\n\n"
+ "[ldap]\n"
+ "ldap.max_links = -1\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}