$re = '/(?<=\n)\[.*\]\n+(?=\[)/';
$str = '
mssql.min_error_severity = 10
mssql.min_message_severity = 10
mssql.compatibility_mode = Offmssql.secure_connection = Off[Tidy]
tidy.clean_output = Off
[soap]
soap.wsdl_cache_enabled=1
soap.wsdl_cache_dir="/tmp"
soap.wsdl_cache_ttl=86400
soap.wsdl_cache_limit = 5
[sysvshm]
[ldap]
ldap.max_links = -1
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);