re = /^\s*(count)\s+"[^"]+"\s*((tsr|sum)\s+(<|<<)\s+("[^"]+"|[-+]?[0-9]*\.?[0-9]+))?\s*$/i
str = 'count hede'
# Print the match result
str.match(re) do |match|
puts match.to_s
end