$re = '/^\s*(count)\s+"[^"]+"\s*((tsr|sum)\s+(<|<<)\s+("[^"]+"|[-+]?[0-9]*\.?[0-9]+))?\s*$/i';
$str = 'count hede';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);