const regex = /^\s*(count)\s+"[^"]+"\s*((tsr|sum)\s+(<|<<)\s+("[^"]+"|[-+]?[0-9]*\.?[0-9]+))?\s*$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(count)\\s+"[^"]+"\\s*((tsr|sum)\\s+(<|<<)\\s+("[^"]+"|[-+]?[0-9]*\\.?[0-9]+))?\\s*$', 'i')
const str = `count hede`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}