const regex = /(?<!animations|foreach|completion|block|dispatch|configuration|mas_makeConstraints|dispatchUI):\s*(\^(?!\))[^{;]*\{\s+(?!\s*@strongify\(self)[^{}]*?\b(?:self|_)(?!\s+class))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!animations|foreach|completion|block|dispatch|configuration|mas_makeConstraints|dispatchUI):\\s*(\\^(?!\\))[^{;]*\\{\\s+(?!\\s*@strongify\\(self)[^{}]*?\\b(?:self|_)(?!\\s+class))', 'gm')
const str = ` [[RACObserve(self, model) ignore:nil] subscribeNext: ^(id value) {
// UI配置
@strongify(self);
MyBarModel *myBarModel = (MyBarModel*) value;
[self.imgBar sd_setImageWithURL:[NSURL URLWithString:myBarModel.barImgUrl]
placeholderImage:[UIImage imageNamed:@"logo-bar"]];
self.lblBarTitle.text = myBarModel.barName;
self.lblBarDescription.text = myBarModel.barDesc;
self.barDescriptionTextField.text = myBarModel.barDesc;
self.cellType = DDMyInstallBarCellTypeFinish;
}];`;
const subst = `\1,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);