import Foundation
let pattern = #"(?<!animations|foreach|completion|block|dispatch|configuration|mas_makeConstraints|dispatchUI):\s*(\^(?!\))[^{;]*\{\s+(?!\s*@strongify\(self)[^{}]*?\b(?:self|_)(?!\s+class))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[[RACObserve(self, model) ignore:nil] subscribeNext: ^(id value) {
// UI配置
@strongify(self);
MyBarModel *myBarModel = (MyBarModel*) value;
[self.imgBar sd_setImageWithURL:[NSURL URLWithString:myBarModel.barImgUrl]
placeholderImage:[UIImage imageNamed:@"logo-bar"]];
self.lblBarTitle.text = myBarModel.barName;
self.lblBarDescription.text = myBarModel.barDesc;
self.barDescriptionTextField.text = myBarModel.barDesc;
self.cellType = DDMyInstallBarCellTypeFinish;
}];
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)