#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!animations|foreach|completion|block|dispatch|configuration|mas_makeConstraints|dispatchUI):\s*(\^(?!\))[^{;]*\{\s+(?!\s*@strongify\(self)[^{}]*?\b(?:self|_)(?!\s+class))"
Local $sString = " [[RACObserve(self, model) ignore:nil] subscribeNext: ^(id value) {" & @CRLF & _
" // UI配置" & @CRLF & _
" @strongify(self);" & @CRLF & _
" MyBarModel *myBarModel = (MyBarModel*) value;" & @CRLF & _
" [self.imgBar sd_setImageWithURL:[NSURL URLWithString:myBarModel.barImgUrl]" & @CRLF & _
" placeholderImage:[UIImage imageNamed:@"logo-bar"]];" & @CRLF & _
" self.lblBarTitle.text = myBarModel.barName;" & @CRLF & _
" self.lblBarDescription.text = myBarModel.barDesc;" & @CRLF & _
" self.barDescriptionTextField.text = myBarModel.barDesc;" & @CRLF & _
" self.cellType = DDMyInstallBarCellTypeFinish;" & @CRLF & _
" }];"
Local $sSubst = "\1,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)