re = /(?!.*?\/)(?P<image>.*?)(?:\.(?:jpg|png))/
str = 'data/products/rosewood/gigwi_crunchy_neck_lion_medium.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end