using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!.*?\/)(?P<image>.*?)(?:\.(?:jpg|png))";
string input = @"data/products/rosewood/gigwi_crunchy_neck_lion_medium.jpg";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}