$re = '/(?!.*?\/)(?P<image>.*?)(?:\.(?:jpg|png))/';
$str = 'data/products/rosewood/gigwi_crunchy_neck_lion_medium.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);