re = /^(?!.*(word).*$)([^\n]*)/m
str = 'sentence that contains the word
word
sentence that does not contains the w.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end