const regex = /^(?!.*(word).*$)([^\n]*)/ms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*(word).*$)([^\\n]*)', 'ms')
const str = `sentence that contains the word
word
sentence that does not contains the w.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}