$re = '/^(?!.*(word).*$)([^\n]*)/ms';
$str = 'sentence that contains the word
word
sentence that does not contains the w.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);