# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=params\.).*?(?=\])"
test_str = ("function pastEvents(username, params) { // 305\n"
" /** //\n"
" * @description Docs: http://www.songkick.com/developer/past-events-for-user //\n"
" * @param {string} username //\n"
" * @param {object} [params={}] //\n"
" * @param {number} [params.page=1] //\n"
" * @param {number} [params.per_page=50] - 50 is the max //\n"
" * @param {string} [params.order='asc'] - 'asc' or 'desc' //\n"
" * @returns {Promise} //\n"
" */ //\n"
" params = params ? params : {}; // 315\n"
" var url = _this.user.baseURL + username + '/gigography.' + _this.format + '?apikey='; // 316\n"
" return _performRequest(url, params); // 318\n"
" }")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.