using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=params\.).*?(?=\])";
string input = @"function pastEvents(username, params) { // 305
/** //
* @description Docs: http://www.songkick.com/developer/past-events-for-user //
* @param {string} username //
* @param {object} [params={}] //
* @param {number} [params.page=1] //
* @param {number} [params.per_page=50] - 50 is the max //
* @param {string} [params.order='asc'] - 'asc' or 'desc' //
* @returns {Promise} //
*/ //
params = params ? params : {}; // 315
var url = _this.user.baseURL + username + '/gigography.' + _this.format + '?apikey='; // 316
return _performRequest(url, params); // 318
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}