$re = '/(?<=params\.).*?(?=\])/m';
$str = 'function pastEvents(username, params) { // 305
/** //
* @description Docs: http://www.songkick.com/developer/past-events-for-user //
* @param {string} username //
* @param {object} [params={}] //
* @param {number} [params.page=1] //
* @param {number} [params.per_page=50] - 50 is the max //
* @param {string} [params.order=\'asc\'] - \'asc\' or \'desc\' //
* @returns {Promise} //
*/ //
params = params ? params : {}; // 315
var url = _this.user.baseURL + username + \'/gigography.\' + _this.format + \'?apikey=\'; // 316
return _performRequest(url, params); // 318
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);