use strict;
my $str = 'недревесное сырье:,Актинидия (15) 0,7 м,1,5 кг/га
недревесное сырье:,Калина (10) 1,2 м,0,1 кг/га
недревесное сырье:,Актинидия (15) 0,7 м,3,5 кг/га,Лимонник (15) 3,5 м,3,5 кг/га,
недревесное сырье:,Лимонник (10) 2,0 м,1,0 кг/га
недревесное сырье:,ЭЛЕУТЕРОКОКК (5) 2,0 м,0,5 кг/га
недревесное сырье:,Лимонник (10) 2,0 м,0,2 кг/га,Виноград (10) 2,0 м,0,1 кг/га
недревесное сырье:кедровый орех,аралия (5) 2,4 м,1,8 кг/га
недревесное сырье:орехи,Лещина (10) 5,0 м,20,0 кг/га
недревесное сырье:,Актинидия (10) 0,4 м,3,5 кг/га,Виноград (15) 0,3 м,0,2 кг/га
';
my $regex = qr/^()/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}