#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^()"
Local $sString = "недревесное сырье:,Актинидия (15) 0,7 м,1,5 кг/га" & @CRLF & _
"недревесное сырье:,Калина (10) 1,2 м,0,1 кг/га" & @CRLF & _
"недревесное сырье:,Актинидия (15) 0,7 м,3,5 кг/га,Лимонник (15) 3,5 м,3,5 кг/га," & @CRLF & _
"недревесное сырье:,Лимонник (10) 2,0 м,1,0 кг/га" & @CRLF & _
"недревесное сырье:,ЭЛЕУТЕРОКОКК (5) 2,0 м,0,5 кг/га" & @CRLF & _
"недревесное сырье:,Лимонник (10) 2,0 м,0,2 кг/га,Виноград (10) 2,0 м,0,1 кг/га" & @CRLF & _
"недревесное сырье:кедровый орех,аралия (5) 2,4 м,1,8 кг/га" & @CRLF & _
"недревесное сырье:орехи,Лещина (10) 5,0 м,20,0 кг/га" & @CRLF & _
"недревесное сырье:,Актинидия (10) 0,4 м,3,5 кг/га,Виноград (15) 0,3 м,0,2 кг/га" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")