import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^()";
final String string = "недревесное сырье:,Актинидия (15) 0,7 м,1,5 кг/га\n"
+ "недревесное сырье:,Калина (10) 1,2 м,0,1 кг/га\n"
+ "недревесное сырье:,Актинидия (15) 0,7 м,3,5 кг/га,Лимонник (15) 3,5 м,3,5 кг/га,\n"
+ "недревесное сырье:,Лимонник (10) 2,0 м,1,0 кг/га\n"
+ "недревесное сырье:,ЭЛЕУТЕРОКОКК (5) 2,0 м,0,5 кг/га\n"
+ "недревесное сырье:,Лимонник (10) 2,0 м,0,2 кг/га,Виноград (10) 2,0 м,0,1 кг/га\n"
+ "недревесное сырье:кедровый орех,аралия (5) 2,4 м,1,8 кг/га\n"
+ "недревесное сырье:орехи,Лещина (10) 5,0 м,20,0 кг/га\n"
+ "недревесное сырье:,Актинидия (10) 0,4 м,3,5 кг/га,Виноград (15) 0,3 м,0,2 кг/га\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}