$re = '/^([01]?[0-9]|2[0-3]):([0-5]?[0-9])$/m';
$str = '7:4
20:20
00:00
01:59
10:00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);