package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([01]?[0-9]|2[0-3]):([0-5]?[0-9])$`)
var str = `7:4
20:20
00:00
01:59
10:00
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}