const regex = /^([01]?[0-9]|2[0-3]):([0-5]?[0-9])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([01]?[0-9]|2[0-3]):([0-5]?[0-9])$', 'gm')
const str = `7:4
20:20
00:00
01:59
10:00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}