use strict;
my $str = 'ISNULL(column, 0),column2 alias, column3,ISNULL(column, 0, alksd, dlsaksla),column2 alias, array_position(ARRAY[\'f\', \'p\', \'i\', \'a\']::varchar[], x_field),column3,ISNULL(column, 0),column2 alias, column3,ISNULL(column, 0),column2 alias, column3';
my $regex = qr/,(?![^(]*\))/mip;
my $subst = ' DESC,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";