import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(?![^(]*\\))";
final String string = "ISNULL(column, 0),column2 alias, column3,ISNULL(column, 0, alksd, dlsaksla),column2 alias, array_position(ARRAY['f', 'p', 'i', 'a']::varchar[], x_field),column3,ISNULL(column, 0),column2 alias, column3,ISNULL(column, 0),column2 alias, column3";
final String subst = " DESC,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}