// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?x) # free-spacing mode
(?(DEFINE)
# decimal to decimal: 1.2% to 21.53%
(?<dec_to_dec>
(?:[0-9]{1,3}[\,\.][0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\,\.][0-9]{1,3}[\%])
)
# Decimal to Whole number: 1.2% to 21%
(?<dec_to_int>
(?:[0-9]{1,3}[\,\.][0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\%])
)
# Whole number to Decimal: 1% to 21.53%
(?<int_to_dec>
(?:[0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\,\.][0-9]{1,3}[\%])
)
# Whole number to whole number: 1% to 21%
(?<int_to_int>
(?:[0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\%])
)
# Single Whole Number: 21%
(?<single_int>
(?:[0-9]{1,3}[\%])
)
# Single Whole Number: 21%
(?<single_dec>
(?:[0-9]{1,3}[\,\.][0-9]{1,3}[\%])
)
)
(?&dec_to_dec)|(?&dec_to_int)|(?&int_to_dec)|(?&int_to_int)|(?&single_int)|(?&single_dec)").unwrap();
let string = "France: 2.8% to 21%";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}