use strict;
my $str = 'France: 2.8% to 21%';
my $regex = qr/(?x) # free-spacing mode
(?(DEFINE)
# decimal to decimal: 1.2% to 21.53%
(?<dec_to_dec>
(?:[0-9]{1,3}[\,\.][0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\,\.][0-9]{1,3}[\%])
)
# Decimal to Whole number: 1.2% to 21%
(?<dec_to_int>
(?:[0-9]{1,3}[\,\.][0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\%])
)
# Whole number to Decimal: 1% to 21.53%
(?<int_to_dec>
(?:[0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\,\.][0-9]{1,3}[\%])
)
# Whole number to whole number: 1% to 21%
(?<int_to_int>
(?:[0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\%])
)
# Single Whole Number: 21%
(?<single_int>
(?:[0-9]{1,3}[\%])
)
# Single Whole Number: 21%
(?<single_dec>
(?:[0-9]{1,3}[\,\.][0-9]{1,3}[\%])
)
)
(?&dec_to_dec)|(?&dec_to_int)|(?&int_to_dec)|(?&int_to_int)|(?&single_int)|(?&single_dec)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}