const regex = /(?x) # free-spacing mode
(?(DEFINE)
# decimal to decimal: 1.2% to 21.53%
(?<dec_to_dec>
(?:[0-9]{1,3}[\,\.][0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\,\.][0-9]{1,3}[\%])
)
# Decimal to Whole number: 1.2% to 21%
(?<dec_to_int>
(?:[0-9]{1,3}[\,\.][0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\%])
)
# Whole number to Decimal: 1% to 21.53%
(?<int_to_dec>
(?:[0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\,\.][0-9]{1,3}[\%])
)
# Whole number to whole number: 1% to 21%
(?<int_to_int>
(?:[0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\%])
)
# Single Whole Number: 21%
(?<single_int>
(?:[0-9]{1,3}[\%])
)
# Single Whole Number: 21%
(?<single_dec>
(?:[0-9]{1,3}[\,\.][0-9]{1,3}[\%])
)
)
(?&dec_to_dec)|(?&dec_to_int)|(?&int_to_dec)|(?&int_to_int)|(?&single_int)|(?&single_dec)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?x) # free-spacing mode
(?(DEFINE)
# decimal to decimal: 1.2% to 21.53%
(?<dec_to_dec>
(?:[0-9]{1,3}[\\,\\.][0-9]{1,3}[\\%]\\sto\\s[0-9]{1,3}[\\,\\.][0-9]{1,3}[\\%])
)
# Decimal to Whole number: 1.2% to 21%
(?<dec_to_int>
(?:[0-9]{1,3}[\\,\\.][0-9]{1,3}[\\%]\\sto\\s[0-9]{1,3}[\\%])
)
# Whole number to Decimal: 1% to 21.53%
(?<int_to_dec>
(?:[0-9]{1,3}[\\%]\\sto\\s[0-9]{1,3}[\\,\\.][0-9]{1,3}[\\%])
)
# Whole number to whole number: 1% to 21%
(?<int_to_int>
(?:[0-9]{1,3}[\\%]\\sto\\s[0-9]{1,3}[\\%])
)
# Single Whole Number: 21%
(?<single_int>
(?:[0-9]{1,3}[\\%])
)
# Single Whole Number: 21%
(?<single_dec>
(?:[0-9]{1,3}[\\,\\.][0-9]{1,3}[\\%])
)
)
(?&dec_to_dec)|(?&dec_to_int)|(?&int_to_dec)|(?&int_to_int)|(?&single_int)|(?&single_dec)', 'gm')
const str = `France: 2.8% to 21%`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}