re = /^(?:(?<Number>)(?<Prime>(?<SmallestFactor>(?<char>.)\<char>+?))(?:\<SmallestFactor>+(?<-Prime>(?=)))?(?!\<char>)(?<-char>)(?(Prime)(?<-SmallestFactor>)(?<-Number>)|(?<Composite-Number>))|(?<Unit>.)|(?<MustUseTheSameCharacter>.+))$|(?<Zero>^$)/m
str = 'asdfaffafasdddafafasdfasddfasdfffdasssadfassdfsadfasd1111
1111111111111111111111111111111111111111111111111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end