$re = '/^(?:(?<Number>)(?<Prime>(?<SmallestFactor>(?<char>.)\<char>+?))(?:\<SmallestFactor>+(?<-Prime>(?=)))?(?!\<char>)(?<-char>)(?(Prime)(?<-SmallestFactor>)(?<-Number>)|(?<Composite-Number>))|(?<Unit>.)|(?<MustUseTheSameCharacter>.+))$|(?<Zero>^$)/m';
$str = 'asdfaffafasdddafafasdfasddfasdfffdasssadfassdfsadfasd1111
1111111111111111111111111111111111111111111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);