import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?<Number>)(?<Prime>(?<SmallestFactor>(?<char>.)\\<char>+?))(?:\\<SmallestFactor>+(?<-Prime>(?=)))?(?!\\<char>)(?<-char>)(?(Prime)(?<-SmallestFactor>)(?<-Number>)|(?<Composite-Number>))|(?<Unit>.)|(?<MustUseTheSameCharacter>.+))$|(?<Zero>^$)";
final String string = "asdfaffafasdddafafasdfasddfasdfffdasssadfassdfsadfasd1111\n"
+ "1111111111111111111111111111111111111111111111111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}