re = /^(?:(https?:\/\/)?([^:\/$]{1,})(?::(\d{1,}))?(?:($|\/(?:[^?#]{0,}))?((?:\?(?:[^#]{1,}))?)?(?:(#(?:.*)?)?|$)))$/
str = 'https://www.youtu.be:80/UCsRd7WVROeTytsoKddoYVFg?g=1#2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end