package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:(https?:\/\/)?([^:/$]{1,})(?::(\d{1,}))?(?:($|\/(?:[^?#]{0,}))?((?:\?(?:[^#]{1,}))?)?(?:(#(?:.*)?)?|$)))$`)
var str = `https://www.youtu.be:80/UCsRd7WVROeTytsoKddoYVFg?g=1#2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}