import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(https?:\\/\\/)?([^:/$]{1,})(?::(\\d{1,}))?(?:($|\\/(?:[^?#]{0,}))?((?:\\?(?:[^#]{1,}))?)?(?:(#(?:.*)?)?|$)))$";
final String string = "https://www.youtu.be:80/UCsRd7WVROeTytsoKddoYVFg?g=1#2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}