use strict;
my $str = '
"content_url": "https://strm.yandex.ru/kal/probusiness_cv_supres/probusiness_cv_supres0.m3u8?from=unknown&partner_id=188262&target_ref=https%3A//yastatic.net&uuid=42b7c9a63d2c656ab5dc8c5ec0934d6f&video_category_id=1017';
my $regex = qr/(?<=https:\/\/strm.yandex.ru\/kal\/)(.*?)(?=\/)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}