const regex = /(?<=https:\/\/strm.yandex.ru\/kal\/)(.*?)(?=\/)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=https:\\\/\\\/strm.yandex.ru\\\/kal\\\/)(.*?)(?=\\\/)', '')
const str = `
"content_url": "https://strm.yandex.ru/kal/probusiness_cv_supres/probusiness_cv_supres0.m3u8?from=unknown&partner_id=188262&target_ref=https%3A//yastatic.net&uuid=42b7c9a63d2c656ab5dc8c5ec0934d6f&video_category_id=1017`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}