#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=https:\/\/strm.yandex.ru\/kal\/)(.*?)(?=\/)"
Local $sString = "" & @CRLF & _
""content_url": "https://strm.yandex.ru/kal/probusiness_cv_supres/probusiness_cv_supres0.m3u8?from=unknown&partner_id=188262&target_ref=https%3A//yastatic.net&uuid=42b7c9a63d2c656ab5dc8c5ec0934d6f&video_category_id=1017"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")