import Foundation
let pattern = #"(.*)p\.PERSONAL=[^&]*(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
zeit.BUCHUNGSTAG=[2017-11-01T00%3A00%3A00;2018-02-01T23%3A59%3A59]&_viewjoins=zeit|ba|ma|p&p.PERSONAL=in[deil_felix;lechner_carina]&fdf=dfuebfek
p.PERSONAL=in[deil_felix;lechner_carina]&zeit.BUCHUNGSTAG=[2017-11-01T00%3A00%3A00;2018-02-01T23%3A59%3A59]&_viewjoins=zeit|ba|ma|p
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)