# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)p\.PERSONAL=[^&]*(.*)"
test_str = ("zeit.BUCHUNGSTAG=[2017-11-01T00%3A00%3A00;2018-02-01T23%3A59%3A59]&_viewjoins=zeit|ba|ma|p&p.PERSONAL=in[deil_felix;lechner_carina]&fdf=dfuebfek\n\n"
"p.PERSONAL=in[deil_felix;lechner_carina]&zeit.BUCHUNGSTAG=[2017-11-01T00%3A00%3A00;2018-02-01T23%3A59%3A59]&_viewjoins=zeit|ba|ma|p")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.