import Foundation
let pattern = #"^(?:(?:31-(?:0?[13578]|1[02]))-|(?:(?:29|30)-(?:0?[1,3-9]|1[0-2])-))(?:(?:19|20)?\d{2})|(?:29-0?2-(?:(?:(?:19|20)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))|(?:0?[1-9]|1\d|2[0-8])(?:(?:0?[1-9])|(?:1[0-2]))-(?:(?:19|20)?\d{2})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"31-07-2005"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)