$re = '/^(?:(?:31-(?:0?[13578]|1[02]))-|(?:(?:29|30)-(?:0?[1,3-9]|1[0-2])-))(?:(?:19|20)?\d{2})|(?:29-0?2-(?:(?:(?:19|20)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))|(?:0?[1-9]|1\d|2[0-8])(?:(?:0?[1-9])|(?:1[0-2]))-(?:(?:19|20)?\d{2})$/';
$str = '31-07-2005';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);