import Foundation
let pattern = #"RDATE(?:(?:;(?<value_param>VALUE=(?<value_param_type>DATE-TIME|DATE|PERIOD)))|;(?<tzid_param>TZID=(?<tzid_param_tz>[\w\/-]+))|;(?:(?!VALUE|TZID)\w+=[a-zA-Z0-9_\-\/]+))+:(?<value>(?:.*))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"RDATE;FAKE=fake;VALUE=DATE-TIME;TZID=America/New_York:19970714T083000"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}