#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "RDATE(?:(?:;(?<value_param>VALUE=(?<value_param_type>DATE-TIME|DATE|PERIOD)))|;(?<tzid_param>TZID=(?<tzid_param_tz>[\w\/-]+))|;(?:(?!VALUE|TZID)\w+=[a-zA-Z0-9_\-\/]+))+:(?<value>(?:.*))"
Local $sString = "RDATE;FAKE=fake;VALUE=DATE-TIME;TZID=America/New_York:19970714T083000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")