const regex = /RDATE(?:(?:;(?<value_param>VALUE=(?<value_param_type>DATE-TIME|DATE|PERIOD)))|;(?<tzid_param>TZID=(?<tzid_param_tz>[\w\/-]+))|;(?:(?!VALUE|TZID)\w+=[a-zA-Z0-9_\-\/]+))+:(?<value>(?:.*))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('RDATE(?:(?:;(?<value_param>VALUE=(?<value_param_type>DATE-TIME|DATE|PERIOD)))|;(?<tzid_param>TZID=(?<tzid_param_tz>[\\w\\\/-]+))|;(?:(?!VALUE|TZID)\\w+=[a-zA-Z0-9_\\-\\\/]+))+:(?<value>(?:.*))', '')
const str = `RDATE;FAKE=fake;VALUE=DATE-TIME;TZID=America/New_York:19970714T083000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}