re = /^((00|\+)[0-9]{2,5}|0)[1-9][0-9]{8,9}$/m
str = '0566227662
0566227662
0041566227662
+41566227662'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end