using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((00|\+)[0-9]{2,5}|0)[1-9][0-9]{8,9}$";
string input = @"0566227662
0566227662
0041566227662
+41566227662";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}